Install Scope 4.X in a MacOS 9

An area for people to discuss Scope related problems, issues, etc.

Moderators: valis, garyb

Post Reply
MaximKorobov
Posts: 14
Joined: Sun Mar 14, 2021 10:42 am

Install Scope 4.X in a MacOS 9

Post by MaximKorobov »

Recently I:
  • Asked about MacOS compatibilty. Thank you guys!
  • Purchased latest G4 model + keyboard
  • Installed 10.4 and 9.2.2 dual boot
  • Found, purchased and installed Pulsar 2
  • Got Scope 4.5 installer from seller and second version from gary/soniccore
Now there is installation problem - Cannot load dll. What to do to fix that?
Here's photo of error: https://photos.app.goo.gl/EjZprcSJ9i2y2Xh38
Used StuffIt Expander 7.0.3 to unzip archive.
User avatar
astroman
Posts: 8200
Joined: Fri Feb 08, 2002 4:00 pm
Location: Germany

Re: Install Scope 4.X in a MacOS 9

Post by astroman »

Iirc on MacOS9 there was a problem with pathnames if the disk name contains spaces.
Renaming the disk should solve it (mac os 9 to macos9)

best of luck, Tom
MaximKorobov
Posts: 14
Joined: Sun Mar 14, 2021 10:42 am

Re: Install Scope 4.X in a MacOS 9

Post by MaximKorobov »

I copied alloc.dll, crossdev.dll to System -> Extensions, reboot, started SCOPE Platform installer again - no results. Extensions now missing, same error like on link above.
MaximKorobov
Posts: 14
Joined: Sun Mar 14, 2021 10:42 am

Re: Install Scope 4.X in a MacOS 9

Post by MaximKorobov »

Thank you for idea.

I have no luck - it didn't help: https://photos.app.goo.gl/PwwVq5wxVwP4Z5Lp9.

Will try: remove temporary OASYS PCI and PowerCore PCI until setup success.
User avatar
astroman
Posts: 8200
Joined: Fri Feb 08, 2002 4:00 pm
Location: Germany

Re: Install Scope 4.X in a MacOS 9

Post by astroman »

If you have the G4 MDD (mirror drive door) as this was the latest G4 model, then it may be one of it‘s bizarre errors introduced by memory modules.
Remove the modules and check if all are identical or different brands. Ideally you have some with Apple printed on them.
Use only these, the installer doesn‘t need much memory anyway.
Without an Apple label on the module it‘s trial and error - just use a single one to install and exchange if failure continues.

I‘ve been through this myself once when we bought a memory expansion according to specs, but not from Apple.
Suddenly the Oracle server threw error messages that didn‘t make any sense. I considered it a disk error, replaced the server by a backup (from a known working installation), same errors.
Then I remembered the memory upgrade a couple of days ago, removed the chips and all of a sudden the problem was gone.
Plugged in the chips again - problem returned.
MaximKorobov
Posts: 14
Joined: Sun Mar 14, 2021 10:42 am

Re: Install Scope 4.X in a MacOS 9

Post by MaximKorobov »

Removing other DSPs didn't help.
Thank you for new idea. Will try and report the results.
BTW, I found old topic with same symptoms and your response: viewtopic.php?f=1&t=29173&p=266465&hilit=mac#p266465
MaximKorobov
Posts: 14
Joined: Sun Mar 14, 2021 10:42 am

Re: Install Scope 4.X in a MacOS 9

Post by MaximKorobov »

One more topic: viewtopic.php?f=1&t=20683.

Switched between 1 256 MB RAM board and four other 512 MB boards. The problem is not in RAM.

One more idea - G4 have 2 HDD. Possible OS9 don't like that it was installed on a second HDD.
MaximKorobov
Posts: 14
Joined: Sun Mar 14, 2021 10:42 am

Re: Install Scope 4.X in a MacOS 9

Post by MaximKorobov »

I think I found what's the problem.

I found that in 7-Zip on Windows PC file extensions are not the same like on PPC G4 OS9 unzipped folder.

SCOPE_Platform4.5_MAC.zip was unzipped using StuffIt Expander. It expands not not only root file, but when he see bin-file, like SCOPE_Platform4.5_MAC.zip\SCOPE_Platform4.0 Folder\Setup\Bin\PepBase\\PepAtom.dll.bin, he tried to unzip it to - create new folder PepAtom.dll, move content to it's folder.

So unzip folder once again using MacZip 1.06. and... Viola! https://photos.app.goo.gl/hHANiSpjyC9j9qSs8

Hope this message will help for those who will use Creamware stuff in 2031!
User avatar
astroman
Posts: 8200
Joined: Fri Feb 08, 2002 4:00 pm
Location: Germany

Re: Install Scope 4.X in a MacOS 9

Post by astroman »

cool find... 8)
Coincidence here just yesterday: sent a bunch of folders (zipped under OSX High Sierra) to someone, but they didn‘t unzip at the receiver. Instead a „no file or folder inside“ error message popped up.
I got the very same message when I tried to unzip the folder on the machine that formerly compressed them. WTF.
Moving the target folders into a less complex structure made both zipping and unzipping succeed. Bizarre...

have fun on your OS9 system :D
User avatar
valis
Posts: 6224
Joined: Sun Sep 23, 2001 4:00 pm
Location: West Coast USA
Contact:

Re: Install Scope 4.X in a MacOS 9

Post by valis »

I use Keka on MacOS now, doubt there’s on OS9 version but for modern Mac this helped with many rar & zip issues.
Post Reply