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Integrating Your
Recording Software
In addition to the VDAT plug-in, you can
also use your usual recording software
to record audio and MIDI tracks. Thanks
to the large number of drivers and
interfaces supported, SFP transforms
your computer and your diverse audio and
MIDI applications into an outstanding,
integrated digital audio workstation. You
can continue to use all the features of your
favorite recording software, while
enhancing individual audio and MIDI
tracks with SFP’s advanced mixing, DSP
effects processing, and DSP sound
production capabilities.

Recording Audio Tracks
In principle, the SCOPE Fusion Platform lies ‘upstream’ from your audio recording
software. For typical multitrack recording, the signal path is as follows:
Microphone/Sound source -> AD converter -> DSP card -> SFP software -> recording software
(see illustration next page).

In this example, the signal flow in the SFP software enters via the 16-channel ADAT port
and passes through to the Cubase VST recording program (ASIO) as follows:
(DSP board ADAT input ports -> ) ADAT Source module -> Mixer -> ASIO dest ( -> Cubase VST).

In this chapter you will begin to grasp the
enormous possibilities of working within
this integrated environment as we first
introduce you to the fundamentals. Later
we provide some concrete examples of
how to integrate some of the popular
recording applications - tripleDAT, Cubase
VST, Sonar, and Logic Audio.

Recording
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Typical signal path for recording

convertert unit/
signal source

audio sequencer

DSP board

e.g. [...] ADAT
source

Recording

SFP software

Mixer

e.g. ASIO dest

sequencer inputs (e.g. Cubase
VST)
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Configuring Mixers for
Recording
We’ve used the STM 1632 mixer in this
example. However, other mixers can be
similarly configured. If necessary, consult
the Modules section of this manual for a
full description of the STM 1632 mixer.

In the previous example you could also
simply route the ADAT Source signals
directly through to the ASIO dest module
in the SFP software. In this case, the DSP
card serves only as an IO card. However,
we have inserted the STM 1632 to
preempt the input signals so we can route
them over the STM 1632’s direct outs.
This offers the advantage that all channels
can be handled directly by the STM 1632,
and monitored with individual volume
levels and no delay (latency) during
recording.

Connecting the Mixer

Mixer Settings

Using the Live Bar or the Routing Window,
connect the module representing the
hardware IOs (in this example, the
SCOPE ADAT Source module) to the
mixer inputs. If desired, you can switch
the mixer channels to stereo at this
time.Next, connect the direct outs of the
mixer (D(L/R)1 - D(L/R)24) to the module
representing the software interface to your
recording application (ASIO dest, multiple Wave dest, tripleDAT dest, - in this
example, the ASIO dest module adjusted
to 16 channels). Finally, connect the mix
outputs (OutL + R) to your monitoring
system (e.g. [hardware] analog dest)
and the AUX sends (Aux1 - Aux4) you
use for monitoring to a hardware output
connected to your monitor or headphone
amp.

Open the mixer’s control surface. If the
input signals are already optimal, you
can leave the channel faders at their
default positions. Or, you can process
the signals (gain, effects etc.) before
passing them on to your recording
software if desired.
Using the AUX faders, adjust the
monitor levels the musicians hear during
recording.
You may need to hear previously
recorded tracks when recording, as
when laying down vocal tracks. In this
case bring in the recorded tracks
through additional mixer channels (as
described later in the section Track Playback) and balance them with the others
in the monitor output.

Remember that you can make sequential
connections between modules easily
using the ‘N’ key. See the section
‘Connecting Modules’.

Recording
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Other Recording Setups

Recording MIDI Tracks

One of the outstanding characteristics of
the SCOPE Fusion Platform is the
enormous flexibility you have to route
signals. The following is an example of
one of many possible alternative routings
you could use for multi-track recording.

MIDI communication between the SCOPE
Fusion Platform and a MIDI sequencer
takes place over a software interface
represented by the Midi Sequencer
Source/Dest modules.

In the SCOPE Fusion Platform, a module
output can be connected to several inputs
of other modules. It’s possible, then, to
connect the hardware inputs (e.g. ADAT
Source) to the software interface of your
recording application (e.g. ASIO dest,
tripleDAT dest, Wave dest, etc.) so the
signals pass directly into the recording
application. At the same time, you could
route the hardware input signals into the
mixer inputs. Now you can monitor both
the input signals and the tracks through
the mixer during recording.

Recording

MIDI data sent from the SCOPE Fusion
Platform through the input of the Midi
Sequencer Dest module arrives in the
sequencer at the respecitve MIDI inputs
designated CreamWare Midi In 1-8.
Likewise, MIDI data sent from the
sequencer through CreamWare Midi Out
1-8 enters the SCOPE Fusion Platform at
the output of the MIDI Sequencer Source
module.
The number of MIDI ports available in each
direction is as indcated by the operating
system (default = 2). To register more MIDI
I/Os, first add additional MIDI Sequencer
Source Dest modules, and then restart the
computer.

To route MIDI data from an attached
keyboard to the sequencer you need to
load a [hardware] Midi Source module,
representing one of the SCOPE Fusion
Platform’s physical MIDI inputs, and
connect it to a Midi Sequencer Dest
module.
The [hardware] Midi Source module is
loaded and connected to the Midi
Sequencer dest module as part of the
default project that loads when the Live Bar
starts.

Now, assuming the recorded MIDI track
is to be played back to a MIDI synthesizer,
and you also want to hear the sythesizer
while recording the track, you can proceed
two ways:
a) Connect the [hardware] Midi Source
module to the Sequencer Midi dest
module, and the Sequencer Midi source
to the synthesizer input.
This connection is part of the default
project.
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In your sequencer program, adjust the
MIDI settings so that the incoming MIDI
data is passed through to the [hardware]
MIDI Out (set MIDI echo ‘on’ globally, or
per channel - see your sequencer’s
manual or online help) whereby the signal
arrives back in the SFP environment.

directly connect two outpus to a single
input, you must use the Midi Merger
module to combine the [hardware] Midi
Source and Sequencer Midi source
signals. In this scenario, disable MIDI echo
in the sequencer to avoid doubling the
signal, which could lead to notes misfiring,
delays, or stuck notes.

b) Connect the [hardware] Midi Source
to the Sequencer Midi dest, and also to
the synthesizer’s MIDI input. Now when
you play the keyboard, the MIDI data are
sent simultaneously to the sequencer and
the synthesizer. If you now want to hear
the sequencer track play back, you must
connect the Sequencer Midi source to
the synthesizer input. Because you cannot

a) refer to text

b) refer to text

Recording
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Typical signal path for playback

convertert unit/
monitor
audio sequencer

DSP board
SFP software

sequencer outputs (e.g. Cubase
VST)
e.g. Asio source

Recording

Mixer

e.g. Pulsar analog dest
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Track Playback

A Few Notes

When you play one or more audio tracks
back over the SFP virtual outputs in your
recording software, the signals appear in
the SFP driver modules (Asio source,
Wave source, etc.). From there they can
be led to a mixer, or directly to hardware
outputs.

Load an SFPproject with the necessary
drivers (modules) before starting your
sequencer or audio application. If you
don’t, the application won’t find any
drivers, and will generate an error
message.

Likewise, MIDI tracks playing back from
a sequencer appear in the Sequencer
Midi source module, from where the
signal can be routed to vir tual
synthesizers, or hardware synthesizers
connected to an SFP MIDI out jack
(through a [hardware] MIDI dest module).

Recording

The sample rate in your project must be
identical to the rate used in the audio
recording program.
To avoid having to switch back and forth
between SFP and your sequencer in
SFP’s Desktop Graphics mode, include
the Sequencer remote module in your
project to give you control over the
sequencer’s most important functions.
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Configuring external
Recording Software

In tripleDAT, open the Audio Settings
dialog. Under Select Interface, select the
option Scope/Pulsar.

tripleDAT (PC under
Win9X only)
Make sure the sample rate selected in
the SCOPE Fusion Platfor m (in
Samplerate Settings) is the same as in
your tripleDAT arrangement.
As with other audio programs that use the
SCOPE Fusion Platform ASIO or MME
drivers, the use of tripleDAT requires
loading appropriate modules into the SFP
project. These modules represent the
logical inputs and outputs of the tripleDAT
program.
These modules are called tripleDAT
Source and tripleDAT Dest and are found
in the directory ..\Devices\ Software IOs.
Add these two modules to your SFP
project, and then start tripleDAT.

Recording

Contents

Index

9

Assigning output channels
for playback
tripleDAT provides sixteen virtual outputs.
There are various possibilities for
assigning Arranger tracks to these
outputs, including the abiity to assign multiple tracks to a single output. There are
three ways to assign tracks to outputs:

b) Arranger track menu:

c) Track Mixer:

Right-click on the Output button of any
Arranger track to open a menu in which
you can select the desired output for the
track. If the track is set up as a mono
track, you can select outputs Scope 1 –
Scope 16. If the track is a stereo track,
you can select from among output pairs
Scope 1/2 – Scope 15/16.

The output assignment for any track can
be incremented by clicking on the output
assignment button of the mixer channel
strip for the desired track. (The mono/stereo setting for a track is made in the
Arranger track menu.)

a) Routing Setup dialog:
In this dialog (found in the Options menu),
set the slider for each Arranger track to
the desired output. You can toggle a track
between mono and stereo by doubleclicking on its slider.

stereo
Output button
Output button

mono

Arranger tracks are played back through
the outputs specified by the above
settings. In the SCOPE Fusion Platform
these output signals appear on the
correspondingly-numbered outputs of the
tripleDAT Source module.
Connect the outputs of this module in the
usual way to an SFP mixer or to a
physical output module (e.g. [hardware]
ADAT Dest).

Recording
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Recording
tripleDAT inputs appear in the SCOPE
Fusion Platform as inputs on the tripleDAT
Dest module. Make connections in the
SCOPE Fusion Platform as appropriate
so that signals are delivered to these
inputs as desired (e.g., from [hardware]
ADAT Source to tripleDAT Dest).
To record using the DSP hardware, open
the tripleDAT Record dialog by clicking
the Record button.
Here you can, among other things, enable
any of the sixteen input channels for
recording, and assign them to Arranger
tracks.
For a detailed description of this dialog
and its options, please refer to the
tripleDAT Manual or the built-in Help
system.

Recording
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tripleDAT Remote
Open this dialog by double-clicking on
the tripleDAT Source module, or open
it through the module’s context (rightclick) menu.
With this dialog you can remotely
actuate the transport functions Play and
Stop from within the SCOPE Fusion
Platform. It also permits you to set
locator points with which you can define
multiple start points in tripleDAT. By
clicking the Set Locate button (so that it
turns yellow) and then on one of the
numbered buttons next to it, you set the
corresponding locator point to the current
position of the tripleDAT locator. Once
values have been assigned, you can click
the numbered buttons to set tripleDAT’s
locator directly to the defined starting
positions without the need for switching
from the SFP environment to the
tripleDAT program.

Recording
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Synchronization
tripleDAT as MTC Master
All settings for synchronizing tripleDAT to
another audio device (such as an ADAT
or another sequencer) are adjusted in the
SCOPE Fusion Platform. The tripleDAT
Synchronization dialog (that you may have
used with tripleBOARD) is not accessible.

Now, when you start tripleDAT, the
sequencer will automatically synchronize
itself and follow along.

If necessary you can also specify an
offset (hours:minutes:seconds:frames) in
the corresponding field of the tripleDAT
Remote dialog.
(Format: hours:minutes:seconds:frames)

Sequencer programs can be synchronized
to tripleDAT using MIDI Time Code (MTC).
To do this, connect the MIDI output of the
tripleDAT Source module to the
Sequencer Midi dest module to route the
tripleDAT MTC output to the sequencer.
Open the Options drawer by clicking the
Options tab.
Select the desired frame rate from the
available options (24, 25, 29.97 and 30
fps, the latter two optionally in drop-frame
format). Set your sequencer to
synchronize as a slave to MTC from
CreamWare MIDI In at the selected format
(i.e. frame rate). Refer to the
documentation for your sequencer program if necessary.

Recording
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tripleDAT as MTC Slave
tripleDAT can be synchronized to an MTC
source such as a sequencer program
using MIDI Time Code (MTC).

here according to the number of samples
which are to be played back
simultaneously on your system.

Add the MTCToClk module to your SFP
project and connect its MCS (Motion
Control Signal) and Clk (Clock) pads to
the corresponding pads on the tripleDAT
Source module.
Once this pad is connected, the Slave
checkbox activates automatically. The
tripleDAT Remote module recognizes
automatically that timecode will be applied
and that tripleDAT is to be set up as a
timecode slave. Likewise, the frame rate
of the MTC master is adopted
automatically.
Connect the MTC source (e.g Sequencer
MIDI source or [hardware] Midi source)
to the MIDI input of the MTCToClk module
to route the MTC output to tripleDAT.
When the sequencer starts, tripleDAT
synchronizes to it and starts after the
specified PreRoll time. A certain amount
of pre-load time is required by tripleDAT
in order to play back the samples. You
may need to make some adjustments
Recording
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Synchronization to an ADAT
Sample-accurate synchronization of
tripleDAT to an ADAT is possible with the
optional Sync Plate, represented in the
SFP software by the Syncplate Source
module.

MIDI output of the Syncplate Source
module to the Sequencer Midi Dest
module and configure the sequencer
accordingly.

In this case, you must directly set the
frame rate which the module is to generate from the incoming ADAT signal and
pass along to the sequencer.

Add this module to your project and
connect its MCS (Motion Control Signal)
and Clk (Clock) pads to the corresponding
pads on the tripleDAT Source module.
Once again, the tripleDAT Remote Slave
checkbox is automatically activated.
When synchronizing to an ADAT-type
device via the 9-pin connector, no frame
rate setting is necessar y. Instead,
tripleDAT uses the absolute position
information provided via the interface, and
the interface's clock signal for sampleaccurate synchronization, resulting in
sync much more accurate than is possible
with MTC alone.
When the ADAT star ts, tripleDAT
synchronizes to the ADAT after the
specified PreRoll time.
To synchronize an additional sequencer
program to the same ADAT, connect the

Recording
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Cubase VST (PC version)
To ensure the flawless operation of
Steinberg’s Cubase VST in the SCOPE
Fusion Platform environment, note the
following points:

Otherwise, the following error message
appears:

c) Select the ASIO drivers in Cubase.
To use the driver modules loaded into the
SCOPE Fusion Platform project in
Cubase, open the Cubase Audio system
set-up panel by selecting System, in the
Options->Audio settings menu.

Mac users: See the notes about the Mac
version later in this section and perform
the steps described there to establish
communication before proceeding.

The following dialog appears:

a) Use the same sampling frequency
in each application.
Always check to ensure that the sampling
frequency in the Cubase arrangement is
the same as adjusted in the current SFP
project. The SCOPE Fusion Platform
defaults to a sample rate of 44.1kHz.
b) Make sure an ASIO driver is
available.
The SCOPE Fusion Platform offers
several audio interfaces to the Cubase
VST program in the form of ASIO modules.
You must absolutely make sure that
appropriate ASIO source and dest
modules, configured to the desired number
of channels, are loaded into the project
before you start Cubase VST.
Recording

When you close your SFP/VST
session, shu tdown Cubase VST first,
and then the SFP software. Otherwise
additional error messages will appear.
As an alternative to the use of the
ASIO driver included in the
standard project, you can use
various other ASIO drivers. Details
on these drivers are found in the
Hardware I/O and Driver Modules
section .
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Select ASIO Scope as the ASIO device.
Below you will see fields for Sample Rate
and Audio Clock Source. You cannot
change these values directly; Cubase
automatically configures them for optimal
sync using the SFP settings. However,
you can change the settings in SFP at
any time, in which case a message such
as the following appears (in this case, the
message simply asks you to confirm a
change from 48kHz to 44.1kHz):

Recording

d) Enable background playback

e) Enable the MIDI driver

To guarantee that you will always hear
audio and MIDI playback when using
Cubase and the SCOPE Fusion Platform
select Play in Background in the Options
menu. If this is not selected, playback will
stop whenever you switch to the SFP
software to make a change or adjustment
because Cubase would then be running
in the backround.

By default, the standard project contains
the Sequencer MIDI Source and Dest
modules. Each loaded module represents
one of several posible MIDI interfaces.
You can load these modules several times
in order to have more MIDI ports available
in the sequencer. Each module transmits
or receives its own 16 MIDI channels.

Contents

Index

17

To configure MIDI support in Cubase,
open the MIDI System settings dialog.
Select System... in the Options->MIDI
Setup menu:

In order for the MIDI data arriving at a
physical MIDI input on a DSP card to be
available for use in both programs,
connect the [hardware] Midi source
module to the Sequencer Midi dest
module and also (in parallel) to synth and
sampler modules. Previously recorded
MIDI tracks played back by VST appear
in the SFP environment through the
Sequencer MIDI source module, andare
then routed to SFP devices or to the
[hardware] Midi dest module to control
external devices as desired. If a device’s
MIDI input is already occupied, use the
MIDI Merger module to combine the two
input signals.

f) Enable some Cubase inputs.
The next thing to do is to enable the
Cubase inputs for input. Do this in the VST
Inputs window (Options->VST Inputs).

You should also disable the MIDI Through
option in Cubase (Options->MIDI Setup>System...).

In the Enable MIDI Ins... list check the
CreamWare Midi InX entries.

Recording
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The VST Inputs window appears. This
window shows a number of stereo inputs,
the number of which varies depending on
the number of channels configured for the
ASIO dest module. Enable them all.

g) Assign the Cubase tracks

Master Settings

To avoid having to jump back and forth
among a number of Cubase windows, all
settings for each window are described
together here, even though this is not
necessarily the order in which you would
access them in the normal course of work.

To open the Master window, select VST
Master Mixer from the Options menu:
You can route two channels from Cubase
to SCOPE Fusion Platform using the
master outs.
To send more than two channels to the
SCOPE Fusion Platform you must use
Cubase buses. The buses are
implemented in stereo, so you need one

The input channels listed on the left side
represent the ASIO dest module
channels. On the right, next to the Enable
buttons, you can see which Cubase
channels the respective SFP channels are
routed to.

Recording
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Channel Mixer Settings
bus for every two additional channels. The
number of available buses depends on the
number of channels configured in the
ASIO Source module. Enable as many
buses as you need by clicking the Enable
buttons. For example, to use 8 stereo or
16 mono channels you will need to enable
7 additional buses.

Open the VST Channel Mixer 1 (from the
Options menu):
2
1

In the Cubase Master mixer, configure the
routing for the master and bus outputs.
In the illustration, the Master has been
assigned to “Out1L Scope 16-bit “ (the
display cannot show the full label).
Similarly, buses 2 - 8 have been assigned
to outputs “Out2L Scope 16-bit “ through
“Out8L Scope 16-bit“ respectively.
The master channels and all buses have
now been assigned to appropriate channel
pairs in the ASIO Source module.

First assign the inputs (the ASIO dest
channels) to the audio channels (1). For
each channel, select the input you wish
to record from (CTRL + left-click).
In this example we will record 16 mono
signals to 16 audio tracks in Cubase with
the inputs routed in sequence to the 16
channels. Assigning the channels to
Cubase tracks takes place later.

We want to assign the 16 Cubase tracks
to the ASIO source module, so we select
the Master out for channels 1 and 2, and
buses 2 - 8 for the remaining channels. If
the buses do not appear in the menu, you
have probably not enabled them in the
Master window (see “Master Settings“).

Next, route the channels to the Cubase
outputs (2).

Recording
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h) Enable Multi Record
Finally adjust the pan settings (3). Be
aware that a channel receives the full
signal level only if its pan control is set
full left or full right. Because the Master
and the buses are stereo channels, for a
mono signal you must pan to the left to
assign the full signal to the left master or
bus channel only.
In our example, all odd channels are
panned to the left, and even channels to
the right.

Select Options->Multi Record->Active
to enable recording on several tracks
simultaneously. In the arrangement
window a new column labeled R (Record)
appears. Here you can select which
tracks to record on.

Because16 tracks are enabled, all 16
channels can be recorded simultaneously.

i) Arrangement Settings
For each audio track, assign the desired
playback and record channel. If you select
a single track, its channel settings are
displayed in the Track Info column.
In the example, we’ve assigned the 16
channels one-for-one to the 16 audio
tracks. Because the 4th track is
highlighted its settings are displayed —
for example, the assignment to input “IN
2 R“ (1). As this channel is connected to
the 4th channel of the ASIO dest module,
this channel will be recorded to Cubase
track 4.

Recording

To record on another track, select the
track in the “R“ column, or click on the
“Enable“ (2) field of this track. In the
example we’ve enabled all tracks.

You’ll find more extensive and detailed
information in the VST user manual.
Familiarize yourself with the step-by-step
operation of both programs before
contacting Creamware or Steinberg
Customer Support for help. With a little
time and patience, you’ll soon know your
way around the programs.
Have fun sequencing with SFP and
VST!
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A Few Useful Tips for Mac Cubase VST Users
In the Mac OS the SFP MIDI driver is
integrated with the OMS (Open Music Sy
stem). Therefore, before starting VST for
the first time after installing the SFP
software it is necessary to run the OMS
Setup. For use with Cubase, proceed as
follows:
OMS Setup
The OMS basic installation program is
located in the OMS sub-directory of the
Additional files directory on the Cubase
CD. Run the program to perform a normal
installation during which the required files
are copied to Start Volume:Opcode.
Restart the computer.
After restaring the computer you will find
a directory named OMS in the System
directory. Into this directory copy the file
CreamWare OMS Driver from the
drive:Sfp:Driver directory. (Select the file
and drag it while pressing the ALT key).

Recording

Next, start the SFP application (if it is not
already running) to load the required MIDI
modules. Change to the Start
Volume:Opcode directory and run the
OMS Setup program found under OMS
Applications.
If Apple Talk is running, you will be asked
if it should remain enabled or if should be
switched off.

This is followed by the OMS Driver search
dialog. Here you select the default Interface (e.g. modem and printer with a G4).
Click on the Search button. After a short
pause during which the system is
inspected, the SFP logo appears. Click
OK to cofirm.

Apple Talk may cause MIDI timing
problems if enabled.

The Apple Talk Options dialog gives you
the following choices:
- Always leave it on, without asking
- Turn it back on when done with MIDI
If a Greeting/Info dialog appears, click
continue. Otherwise, call the File ->
Create a New Studio Setup dialog. Exit
by clicking OK.
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Make the ASIO Driver Available
to Cubase
The next dialog shows the completed Studio Setup. Again, confirm with OK. You
are now asked to save this configuration
(normally My Studio Setup or something
similar). After clicking on Save the Studio Setup is displayed in miniature in the
dialog.
Finally select save and make current
from the File menu to save and enable
the Setup.You can now end the OMS Setup procedure by selecting Quit from the
File menu. When you are asked to confirm
(save) the changes, click on save.

In the Cubase folder you will find a
subdirectory named ASIO Drivers. Into
this directory copy the ASIO driver, named
ASIO CreamWare, from the Mac driver
directory (drag it to CubaseDirectory:ASIO Drivers while holding the ALT key).
In your Mac this director y will be
Drive:Sfp:Driver and the file is named
CreamWare ASIO.

Now any application that uses OMS will
recognize the MIDI inputs and outputs.
In the OMS Setup you must also configure
the MIDI interface for background
operation (Standard).

Recording
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Logic Audio (PC version)

1. Record and Playback via ASIO drivers

Emagic’s Logic Audio also supports multiple Wave drivers (16/24 bit), and the
Interleaved driver, any of which can be
used as an alternative to the ASIO driver
described here. References to these
drivers are found at the end of this section.

As an alternative to the use of the ASIO
driver described here, you can use the
ASIO2 drivers. Details on these drivers
(ASIO2 source16, ASIO2 source24,
ASIO2 dest16 and ASIO2 dest24) are
found in the reference section.

Mac users should refer to the notes
about the Mac version in Connections
and perform the steps described there.

To record and play back using the ASIO
drivers, first ensure that the ASIO source
and ASIO dest modules are loaded into
the current project. Each module has a
control surfaceyou can open by doubleclicking on the module in the routing
window. Here you can adjust the number
of channels. Always load and configure
the ASIO modules in the SFP application
before starting Logic Audio.

In general, proceed as you would for any
other MIDI-Audio application:
The drivers (modules) you want (need)
to use must be present in the SFP project,
and the project must already be loaded
and running before you launch the other
program (in this case, Logic).
As far as this applies to MIDI, it means
that you must make sure that the
[hardware] MIDI source/dest and
Sequencer MIDI source/dest modules
are present in your project and
appropriately connected before starting
Logic. Integration of SFP audio I/O
modules into Logic is described below.

Recording

Now start Logic Audio.
In the MIDI Settings dialog, select the
desired MIDI outputs.

For this example we’ll use 16 channels
for both recording and playback. For the
ASIO source module adjust the number
of outs to 16 (click and hold on the value
and move the mouse up or down until
the desired number appears). Next set
the ASIO dest module to 16 ins.
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If a message appears click ‘Try/
ReLaunch’ or click the OK button and
restart Logic.

To select the SCOPE Fusion Platform
ASIO driver in Logic Audio you must select
ASIO Scope in the Audio Hardware &
Driver dialog (-> tab Audio Drivers 2 in
Logic v4.5 or higher) (menu audio).

Recording
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Assigning Inputs and Outputs in Logic
In the Logic Mixer you can route audio
tracks to corresponding channels in the
ASIO module. (Only the first 8 channels
are displayed here. The next 8 Channels
can be assigned similarly.)

Recording:

Playback:

To record an audio signal that is routed to
an SFP ASIO dest module, select the
Logic input for the track you want to
record to. When using mono tracks (button
in the lower left part of the channel strip
in the Logic mixer) the Input (1) in the
selection menu corresponds to channels
1-16 in the ASIO dest module. With stereo tracks, pairs of inputs are indicated.
We set channel 1 to inputs 1, 2; 2 to
inputs 3, 4 etc. In the illustration, the first
8 tracks in logic record signals from the
first 8 channels of the ASIO dest module
(1).

To play a Logic track into an SFP project,
set the output of the Logic track to the
respective Logic output (implemented in
stereo). Logic output 1-2 is assigned to
the first two channels in the ASIO source
module and so on. In the illustration, the
first 8 Logic tracks are routed to the first
8 channels of the ASIO source module
(2).
As you probably want to assign tracks
1,3,5,..., 15 to the left channels and tracks
2,4,6,...,16 to the right channels, adjust
the pan control for all odd tracks to hard
left and for the even ones to hard right.
This ensures that track one is routed to
channel 1, track 2 to channel 2, and so
on.
For further details on recording in Logic
Audio, please refer to the Logic
documentation.

Recording
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A Few Useful Tips for Mac Logic Audio Users
With the Mac OS the Creamware MIDI
driver is integrated with the OMS (Open
Music System). Therefore, before starting
VST for the first time after installing SFP
it is necessary to call the ‘OMS Setup’.
For use with Logic, proceed as follows:

Next, start the SFP application (if it is not
already running) to load the required MIDI
modules. Change to the Start
Volume:Opcode directory and run the
OMS Setup program found under OMS
Applications.

OMS Setup

If Apple Talk is running, you will be asked
if it should remain enabled or if should
be switched off.

You can acquire the basic OMS
installation program for Mac by
downloading
it
from
http://
www.opcode.com/downloads. Run the
program to install OMS as normal in Start
Volume: Opcode. After the installation
restart the computer.
After the computer has rebooted you will
find a folder named OMS in the System
Folder. Into this folder copy the file
CreamWare OMS Driver from
Drive:Sfp:Driver’ (select the file and drag
it while pressing the Alt key).

Recording

Apple Talk may cause MIDI timing
problems if enabled.

The Apple Talk Options dialog offers the
following choices:
-

Always leave it on, without asking

-

Turn it back on when done with MIDI

If a Greeting/Info dialog appears, click on
continue. Otherwise, call the Create a
New Studio Setup dialog from the File>New Studio Setup menu selection. Exit
by clicking OK.

This is followed by the OMS Driver
search dialog. Here you select the
‘default Cut Settings (e.g. modem and
printer with a G4).
Click on the Search button. After a short
pause during which the system is
inspected, the SFP logo appears. Confirm
by clicking OK.
The next dialog indicates the completed
Studio Setup. Again, confirm with OK.
You are now asked to save this
configuration (normally ‘My Studio Setup’ or something similar). After clicking
Save the Studio Setup is shown in
miniature in the dialog.
Finally select save and make current
from the File menu to save and enable
the Setup. You can now end the OMS
Setup procedure by selecting Quit from
the File menu. When you are asked to
confirm (save) the changes, click save.
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Now any application that uses OMS will
recognize the MIDI inputs and outputs.
In the OMS Setup you must also configure
the MIDI interface for background
operation (Standard).

Make the ASIO Driver Available
to Logic
In the Logic folder you will find a
subdirectory named ASIO Drivers. You
must now copy the CreamWare ASIO
driver, named CreamWare ASIO, from the
Mac designated driver directory (drag it
while holding the ‘ALT’ key).
In your Mac this director y will be
Drive:Sfp:Driver and the file is named
CreamWare ASIO.
When you start Logic, open the Audio
System Setup dialog (in the Options
menu under Audio -> Audio Hardware
& Driver) to view and incorporate the
loaded SFP modules in the Logic
environment:

Recording

Open the ASIO folder by clicking on the
triangle to its left.
Select CreamWare ASIO Driver as the
Current Driver. In the Clock Source area
underneath, make sure sync to SFP is
selected.

You can change the sample rate at any
time in the SFP software Samplerate
Settings dialog. Logic will display a
message when the sample rate changes.
To enure that you will always hear MIDI
and audio playback when using Logic and
the SFP software together, make sure
OMS is configured to provide background
operation of the MIDI interface.

Contents

Index

28

To use this interface, proceed as follows:

Sonar (PC only)
We chose Sonar to provide an example
of the use of the Wave modules. The SFP
configuration described here is the same
for other programs that use the standard
operating system drivers (Wave, MME,
Sound Manager) such as Vegas,
CoolEdit Pro, Samplitude, and so on.
Refer to the documentation for these
programs for program-specific settings.

The SCOPE Fusion Platform provides
audio channels to other programs using
the Windows MME interface. In the SFP
software, Wave modules represent MME
drivers. These modules appear to other
programs as CreamWare Record and
CreamWare Playback drivers. The
following diagram shows the routing for
the first two tracks:

CreamWare Record 1/2
Windows-MME
Left CreamWare
Playback 1
Right CreamWare
Playback 1

Recording

1. Load the required Wave modules into
the SFP project.
Generally you can record as many audio
tracks in Sonar as you have loaded into
the SFP project. Since a Wave dest
module appears to other programs (such
as Sonar) as a stereo device, you need
to load 8 Wave dest modules to provide
16 audio tracks. Make sure your SFP
project includes 8 Wave dest modules.

This example uses 16 audio tracks. You
can configure another number of tracks
(2-64) in exactly the same manner as
described here.

The illustration below shows how you can
route input signals through the STM 1632
mixer and send them to Sonar for
recording using the mixer’s direct outs.

The same applies to the Wave source
modules; load as many you need for
playback in Sonar.

Left CreamWare
Record 1
Right CreamWare
Record 1

CreamWare Playback 1/2

Windows-MME
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In this example, 8 channels from a SCOPE
ADAT interface are connected to 8 mixer
inputs, and then sent to the Wave Dest
module through the direct outs for
recording in Sonar.
For processing Sonar audio tracks during
playback and mixdown, 4 Wave source
modules are connected to the next 8 mixer
channels.

2. Load the SFP Wave driver
Now Windows supplies other programs
with SFP Wave drivers. You can check
the number of drivers in the DSP card’s
Driver Setup dialog (Control Panel -> System -> Device manager -> Sound, video
and game controllers -> DSP card ->
Settings):

3. Tell Cakewalk to use the new Wave
drivers
Start Sonar and open the Audio Options
dialog (Options -> Audio...). In the Drivers
panel you will see the new drivers listed.
Highlight all drivers you wish to enable.

Sooner or later, when adding modules,
you’ll probably encounter this dialog:
The "Input Devices“ are represented by
Wave source modules; the "Output
Devices“ by Wave dest modules.
The SFP software is letting you know that
there are not enough reserved Windows
drivers and asks you if you want to
introduce another driver to Windows. Click
Yes, and the software will tell you that
Windows must be restarted for the new
driver to be activated. Before you do so,
load the required number of modules and
save your project. Then restart Windows.

Recording

If you want to make use of these drivers,
you must start SFP and load the previously
created project. With it, you load the Wave
dest modules.
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In the "General" panel make sure the
selected sampling rate (1) is the same
as in the SCOPE Fusion Platform (default
44.1kHz). Select CreamWare Playback
1 and CreamWare Record 1 as timing
master for playback and recording.
Also, make sure that the number of Virtual
Mains set here is the same as the number
of Wave source modules loaded into SFP.
All SFP drivers should be disabled in the
„Input Monitoring“ panel to prevent
feedback loops. It’s better to configure the
input monitoring in the SFP software.
Next, assign the Cakewalk tracks to the
inputs and outputs. In our example we’ll
record all audio signals to mono tracks.

Recording

Record:

Playback:

Select the source to record from in a
track’s In field. For example, if you want
to assign the left channel of the first SFP
Wave dest module to the first track, select
"left CreamWare Record 1“ under Source
(1)

Select the device you want to play the
track back to in a track’s Out field. For
example, if you want to assign the first
track to the left channel of the first SFP
Wave source module, select "CreamWare
Playback 1“ in the Port field (2). In addition,
you must set the track pan hard left (value
0) to make sure the signal appears only
on the left channel of the Wave source
module (3).
In our example, all odd tracks have pan
set to 100% left and all even tracksto
100% right. All track signals will therefore
appear in the appropriate channels in the
SFP mixer.
When recording or playing back stereo
tracks, the pan contorl no longer handles
the signal distribution. For stereo tracks
you need only assign them sequentially
as desired.
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4. The MIDI setup
Open the MIDI Ports dialog of Cakewalk
(Menu: Tools -> MIDI Devices or Options
-> Midi Devices in v9.0). Enable the SFP
MIDI Ports. The default is two MIDI ins
and two MIDI outs. You can specify the
number of MIDI ports in the SFP driver
setup dialog (in the Windows Device Manager).

This example shows how to record MIDI
from your keyboard into Cakewalk using
Pulsar.
The keyboard is connected to the SFP
MIDI input, represented by the ‚Creamware MIDI Source‘ module. This module
is connected to ‚Sequencer MIDI Dest 1‘
so that the MIDI signal will appear as an
input in Cakewalk.

To avoid a doubled sound while
recording, disable echo for the MIDI
channel you are recording or for all MIDI
channels (Echo Mode: None) in
Cakewalk’s Project Options dialog (Tools
-> Project Options -> Midi In):

We want to record a solo using the EZ
Synth. The MIDI signal from ‚Pulsar MIDI
Source‘ is also connected to the input of
the EZ Synth, so we can hear the synth
while playing the keyboard.
Assign sources and ports for each MIDI
track in the Cakewalk Track Properties
dialog which appears when you doubleclick on the source or port field:

Recording

In addition ‚Sequencer MIDI Source 1‘ is
connected to the input of the EZ Synth,
so we can hear the recorded solo when
it is played back from the sequencer. The
MIDI Merger is required in order to
connect both ‚Sequencer MIDI Source 1‘
and ‚Pulsar MIDI Source‘ to the EZ Synth
at the same time.

p.u
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