PlanetZ@scopeusers.com

Scope Users Community
It is currently Fri Nov 24, 2017 5:58 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Ulli-Settings vs. Delaytime
PostPosted: Mon Mar 31, 2014 5:40 am 
Offline
User avatar

Joined: Thu Jan 09, 2003 4:00 pm
Posts: 581
Location: Graz
Hi,
lately I switched my Ulli settings and saw all delaytimes being out of sync.
Is there someone who can tell me the correlation between Ulli & DT (or even got a formula? :) )

_________________
http://www.cwmodular.org/


Top
 Profile  
Reply with quote  
 Post subject: Re: Ulli-Settings vs. Delaytime
PostPosted: Mon Mar 31, 2014 6:55 am 
Offline
User avatar

Joined: Mon Oct 29, 2001 4:00 pm
Posts: 632
Location: No idea. All looks the same down here
Nice timing Roy :)

I'm working on ULLI and sample rate dependent ranges for delays at the moment. If I'm not wrong only delays using host ram should be offset by ULLI setting. Logically this should be a round-trip latency, but I've yet to confirm this.


Top
 Profile  
Reply with quote  
 Post subject: Re: Ulli-Settings vs. Delaytime
PostPosted: Mon Mar 31, 2014 8:27 am 
Offline
User avatar

Joined: Thu Jan 09, 2003 4:00 pm
Posts: 581
Location: Graz
Quote:
Logically this should be a round-trip latency

Thanks sharc, I think you placed me on the right track.

1000ms->48000
1ms->48

the Ulli setting w/ exact delay times was 25ms (44.1kHz)
my new Ulli setting is 3ms
25-3=22
22x48=1056
1056x2(round-trip :wink: )=2112

I added 2112 to delaytime value
>voilĂ  it's in sync again! :)

so it's just that easy for all Ulli settings:
make a textfader string with 5 values, for each Ulli setting.
the values are:
2112 for 3ms
2016 for 4ms
1728 for 7ms
1152 for 13ms
0 for 25ms
and add the textfader value to the delay value.

_________________
http://www.cwmodular.org/


Top
 Profile  
Reply with quote  
 Post subject: Re: Ulli-Settings vs. Delaytime
PostPosted: Mon Mar 31, 2014 12:54 pm 
Offline
User avatar

Joined: Mon Oct 29, 2001 4:00 pm
Posts: 632
Location: No idea. All looks the same down here
Thanks for sharing Roy. That explains why my test results were getting skewed between the SDK and SFP - Different ULLI settings :)


Top
 Profile  
Reply with quote  
 Post subject: Re: Ulli-Settings vs. Delaytime
PostPosted: Mon Mar 31, 2014 9:16 pm 
Offline

Joined: Wed Oct 23, 2013 8:51 pm
Posts: 52
roy thinnes wrote:
Quote:
Logically this should be a round-trip latency

Thanks sharc, I think you placed me on the right track.

1000ms->48000
1ms->48

the Ulli setting w/ exact delay times was 25ms (44.1kHz)
my new Ulli setting is 3ms
25-3=22
22x48=1056
1056x2(round-trip :wink: )=2112

I added 2112 to delaytime value
>voilĂ  it's in sync again! :)

so it's just that easy for all Ulli settings:
make a textfader string with 5 values, for each Ulli setting.
the values are:
2112 for 3ms
2016 for 4ms
1728 for 7ms
1152 for 13ms
0 for 25ms
and add the textfader value to the delay value.


Thanks Roy!

This is very useful information and another wrinkle to development that I hadn't given full consideration. I knew sample delays can introduce significant issues, but thanks to your post I realize the hardware end is by no-means 'hands-free'. :)

_________________
xw8400
2.33 GHz Xeon Quad core (E5345 Socket 771) x2
32Gb ECC buffered memory
AMD HD7700
Samsung 850 EVO 250Gb root drive
Windows 7 Pro (64bit)
Sonar Platinum
XITE-1 (flipping awesome!)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Donate to help support this community


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group