development systems Scope FX, Scope GUI, Open Scope SCOPE 6

A place for developers to share ideas and assist each other in solving problems.

Moderator: valis

Post Reply
DragonSF
Posts: 251
Joined: Sun Nov 08, 2015 4:28 pm

development systems Scope FX, Scope GUI, Open Scope SCOPE 6

Post by DragonSF » Thu Aug 04, 2016 10:44 pm

I'm still try to conceive a FFT module. Instead of using DSP, I was adviced to used C++ and run the FFT native on the host. In order to do this, you need a librarry and some header files. I'm searching around and come to something like 'Scope FX, Scope GUI, Open Scope SCOPE 6', but I can't find a real download for any of those. Please enlighten me.
looks like at least effclass.h and ScopeDLL.lib is required. Where are they now?

jksuperstar
Posts: 1476
Joined: Mon Nov 15, 2010 12:57 pm

Re: development systems Scope FX, Scope GUI, Open Scope SCOP

Post by jksuperstar » Fri Aug 05, 2016 8:02 am

Contact Sonic-core for a SCOPE 6 development kit. However, from most developers, they suggest sticking with SCOPE 5. SCOPE 6 is unreleased, and your host code shouldn't be changed by it.

Just make sure you can compile both 64bit and 32-bit versions :) :) 32-bit is still prevalent, but 64-bit is where things are headed due to RAM addressing beyond 4GB.

DragonSF
Posts: 251
Joined: Sun Nov 08, 2015 4:28 pm

Re: development systems Scope FX, Scope GUI, Open Scope SCOP

Post by DragonSF » Fri Aug 05, 2016 3:15 pm

jksuperstar wrote:Contact Sonic-core for a SCOPE 6 development kit. However, from most developers, they suggest sticking with SCOPE 5. SCOPE 6 is unreleased, and your host code shouldn't be changed by it.

Just make sure you can compile both 64bit and 32-bit versions :) :) 32-bit is still prevalent, but 64-bit is where things are headed due to RAM addressing beyond 4GB.
That's the answer I got from Sonic Core: stick to 5, because 6 is unstable.

User avatar
faxinadu
Posts: 1215
Joined: Wed Nov 01, 2006 3:12 am
Location: israel
Contact:

Re: development systems Scope FX, Scope GUI, Open Scope SCOP

Post by faxinadu » Sun Aug 07, 2016 3:15 am

forget 6, it isn't working and none of the devlopers use it. sdk5 is the version to work with.

Post Reply