Midi data

A place for developers to share ideas and assist each other in solving problems.

Moderators: valis, garyb

Post Reply
winger
Posts: 258
Joined: Fri Dec 21, 2007 1:34 pm

Midi data

Post by winger » Wed Oct 28, 2009 1:07 pm

I am a little confused. I have a couple devices I created and am testing and the issue is that when I load a preset, or load the project, Idon't get all the midi controllers send out. I am trying to symc with and extenal controller and this is a problem.

I have 1 device that has 2 presets, one for 1 set of controlls, and one for a second (eq and compression for a mix channel module). This works fine sending the midi controllers for each preset when loaded.

Another device is like a line mixer. It has one preset file and it loads the preset fine but does not sent the midi controllers when loaded. Is there something that controlls this, preventing the controllers from being sent?

I don't know why one device works and the other does not.?
mark winger

winger
Posts: 258
Joined: Fri Dec 21, 2007 1:34 pm

Re: Midi data

Post by winger » Wed Nov 11, 2009 8:46 am

Ok, I am back on this one again. This problem may have nothing to do with the sdk, but with scope. I have a project with about 30 devices(the mixing devices I am working on), all connected to midi output via2 16 channel midi mergers cascaded. I am trying to use a surface to control everything. When I load the project, I expect to get midi controllers for every control on every device, but I only get maybe 1/4 of all the controls I expect.

Is it possible that the problem is the midi mergers? If 3 devices load, send their data to the mergers all at the same time, we will try to merge 30 midi stream to one. Unless the mergers buffer a lot of data on each input, data will be lost. I think each device is sending about 25 controller.

First, is this a problem? If so, how do I resolve it? Is there a way to get a device to send all it midi parameters without reloading it?
mark winger

winger
Posts: 258
Joined: Fri Dec 21, 2007 1:34 pm

Re: Midi data

Post by winger » Wed Nov 11, 2009 10:36 am

I did some more testing and found some strange behavior. I put one of my devices in a project set the midi channel to 1. Connected the midi out to monitor it.
All the controllers were sent.

I added another on channel 2 and merged the out. Again I got all the controllers.

When I added the 4th I was missing some of the controllers from the 4th device.
Added 2 more and get at most 1 controller from each.

It appears this has nothing to do with the merger, but sfp seems to limit the number of output controls it will send.
I am monitoring with a program on another computer. Every controller set 2 midi commands, first to 0 the cotnroller, and one to set the value.

I get 195 midi commands no matter how many devices I add.
With 4 or 5 devices I get 193.

With 3 devices I get 163(For some reason I get an extra controller occasionally making the number odd). If I got exactly 2 for every one I would expect 54 per device for a total of 162.

I tried 5.0 and no difference.

Does scope limit the number of midi controllers it sends at load time?
mark winger

User avatar
roy thinnes
Posts: 612
Joined: Thu Jan 09, 2003 4:00 pm
Location: Graz
Contact:

Re: Midi data

Post by roy thinnes » Wed Nov 11, 2009 12:31 pm

did you make a test with a stock sc device too? if you are getting the same results, I think it’s OT here cause if it’s true what you found out it’s a general scope problem, not sdk related, so you probably should post it under "Problem Solving". (and you maybe will get more replies too because the number of developers is quite limited.)

winger
Posts: 258
Joined: Fri Dec 21, 2007 1:34 pm

Re: Midi data

Post by winger » Wed Nov 11, 2009 1:14 pm

I was testing that when you replied. Took a lot longer becuase I had to configure controller in the devices, my devices were have default controllers so you don't have to set them up.

I get the exact same result. I used the dynamixer device, and set it to 16 channels. I set the channel faders as 1-16 and the master as 17. Set the midi channel to 1 and it works.

I repeated this multiple times until I had dynamixers on midi channels 0-6.

With 5 dynamixers 173 controllers sent with dynamixers on 0-4. This should send 17*2*5=170.
With 6 dynamixers 197 controllers sent 17*2*6=204. A few were lost here.
With 7 dynamixers 197 controllers send 17*2*7=238. I got 0 controllers sent for channel 6.

Looks like a general sfp problem. I should be able to send 128 midi controllers on all 16 channels and if 2 sent at a time this would be 4096.

Can this thread be moved to problem solving, or do I need to start a new thread there?
mark winger

User avatar
roy thinnes
Posts: 612
Joined: Thu Jan 09, 2003 4:00 pm
Location: Graz
Contact:

Re: Midi data

Post by roy thinnes » Wed Nov 11, 2009 2:47 pm

just start a new thread in ProbSolving, and maybe ask John Cooper if he wants to remove this one or mark as "moved to ProblemSolving" or so.
btw, you cannot use all CC, see here:
http://www.cwmodular.org/html/list2_cc.html

Post Reply