Win 10 - scope driver does not work since recent update

An area for people to discuss Scope related problems, issues, etc.

Moderators: valis, garyb

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Win 10 - scope driver does not work since recent update

Post by mcm060769 » Tue Sep 27, 2016 11:08 am

Hello, during booting my Win10 PC yesterday some updates have been installed. Since that I'm not able to start scope application, only getting the following:
1.JPG
1.JPG (18.86 KiB) Viewed 2923 times
2.JPG
2.JPG (16.12 KiB) Viewed 2923 times
It worked fine until yesterday since July under Win 10.

Any Idea ?

Thanks

Ripper
Posts: 168
Joined: Tue Jan 08, 2013 5:33 am

Re: Win 10 - scope driver does not work since recent update

Post by Ripper » Tue Sep 27, 2016 11:14 am

I suppose it is the driver signing thing, again.

Enable the unsigned drivers permission.

http://forums.scopeusers.com/viewtopic.php?f=1&t=31313

User avatar
garyb
Posts: 21590
Joined: Sun Apr 15, 2001 4:00 pm
Location: ghetto by the sea

Re: Win 10 - scope driver does not work since recent update

Post by garyb » Tue Sep 27, 2016 11:46 am

yep, google "disable driver signature enforcement windows 10" for instructions. after following the directions, reinstall the Scope driver either by choosing "update driver" in the device manager and then manually choosing the Scope driver, or, easier, go to program files\Scope\driver and run the SetupDriverScopePCI.exe

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Re: Win 10 - scope driver does not work since recent update

Post by mcm060769 » Tue Sep 27, 2016 11:51 am

thanks everybody. I'll try these days. Until then, any additional idea is welcome.

User avatar
garyb
Posts: 21590
Joined: Sun Apr 15, 2001 4:00 pm
Location: ghetto by the sea

Re: Win 10 - scope driver does not work since recent update

Post by garyb » Tue Sep 27, 2016 11:59 am

there is no additional idea.

the Scope driver isn't signed by Microsoft.
now that Microsoft considers the operating system to be a service and not a product, they feel that it is within their rights to remove unsigned drivers(i.e. drivers that did not send money to Microsoft for approval) after an update. it's not a big deal.

in the very likely event of an update to Scope, there will probably be a signed driver, just because it's a pain for everyone otherwise, even though it's expensive and will drive up the cost of the update.

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Re: Win 10 - scope driver does not work since recent update

Post by mcm060769 » Tue Sep 27, 2016 12:01 pm

Ok, gary. I'll try and let you know. Thanks

fidox
Posts: 639
Joined: Sun Aug 17, 2003 4:00 pm
Location: Slovenia
Contact:

Re: Win 10 - scope driver does not work since recent update

Post by fidox » Tue Sep 27, 2016 2:36 pm

yes, you need to install scope drivers again after major upgrade to 1607 version.

asktoby
Posts: 137
Joined: Thu Mar 13, 2003 4:00 pm
Contact:

Re: Win 10 - scope driver does not work since recent update

Post by asktoby » Fri Sep 30, 2016 6:32 am

garyb wrote:go to program files\Scope\driver and run the SetupDriverScopePCI.exe
...as administrator.

Thanks!

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Re: Win 10 - scope driver does not work since recent update

Post by mcm060769 » Wed Dec 07, 2016 10:18 am

Hello Everybody,

today I took the time trying to bring my scope card back to life.

I did the following according to above recommendations:

I entered in the comand prompt (as admin) bcdedit /set testsigning on.
After reboot in the right lower corner I recognized the follwing...
testpic.JPG
testpic.JPG (13.4 KiB) Viewed 2626 times
Finally the card does work again.

Thank you all for your help. Overall it took me 15 minutes.

Michael

User avatar
garyb
Posts: 21590
Joined: Sun Apr 15, 2001 4:00 pm
Location: ghetto by the sea

Re: Win 10 - scope driver does not work since recent update

Post by garyb » Wed Dec 07, 2016 11:04 am

use the same method to turn test mode off...

use this command:
bcdedit /set testsigning off

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Re: Win 10 - scope driver does not work since recent update

Post by mcm060769 » Wed Dec 07, 2016 11:10 am

Is that required or recommended ? Assuming scope won't work any longer.

User avatar
garyb
Posts: 21590
Joined: Sun Apr 15, 2001 4:00 pm
Location: ghetto by the sea

Re: Win 10 - scope driver does not work since recent update

Post by garyb » Wed Dec 07, 2016 11:18 am

well, it doesn't matter if you don't use online apps that might install a bad driver without your permission, but the system was designed to run with driver security enabled. it won't matter to Scope once the driver is installed. it's only necessary to disable driver security to install the driver.

is that an authorized version of windows? i usually only see the build version on Windows install that have not been authorized...

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Re: Win 10 - scope driver does not work since recent update

Post by mcm060769 » Wed Dec 07, 2016 11:40 am

Ok, testmode disabled and scope still works.
My Windows is an official copy. An online upgrade from Win7 during the free upgrade period...

User avatar
garyb
Posts: 21590
Joined: Sun Apr 15, 2001 4:00 pm
Location: ghetto by the sea

Re: Win 10 - scope driver does not work since recent update

Post by garyb » Wed Dec 07, 2016 11:45 am

glad it's working!

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Re: Win 10 - scope driver does not work since recent update

Post by mcm060769 » Wed Dec 07, 2016 11:50 am

me, too :)

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Re: Win 10 - scope driver does not work since recent update

Post by mcm060769 » Thu Dec 08, 2016 6:02 am

Hello, today I tried to use the ASIO1 source and the audio application comes up with....
Unbenannt1.JPG
Unbenannt1.JPG (16.86 KiB) Viewed 2578 times
Analog Input and Output are working great...

Any Idea ? --> before the Win10 Issue occured Asio worked fine.

asktoby
Posts: 137
Joined: Thu Mar 13, 2003 4:00 pm
Contact:

Re: Win 10 - scope driver does not work since recent update

Post by asktoby » Thu Dec 08, 2016 6:06 am

Do you have ASIO modules in your project?
Show a screenshot of your routing window.

User avatar
mcm060769
Posts: 24
Joined: Mon Dec 29, 2008 2:21 pm

Re: Win 10 - scope driver does not work since recent update

Post by mcm060769 » Thu Dec 08, 2016 6:09 am

Here you are !
Unbenannt2.JPG
Unbenannt2.JPG (48.09 KiB) Viewed 2576 times

Ripper
Posts: 168
Joined: Tue Jan 08, 2013 5:33 am

Re: Win 10 - scope driver does not work since recent update

Post by Ripper » Thu Dec 08, 2016 10:33 am

Go to services ->Restart Audio Service and Windows Audio Endpoint Builder and check if it fixed the issue.

User avatar
garyb
Posts: 21590
Joined: Sun Apr 15, 2001 4:00 pm
Location: ghetto by the sea

Re: Win 10 - scope driver does not work since recent update

Post by garyb » Thu Dec 08, 2016 10:59 am

did you change the ASIO driver while your audio app was open? the ASIO drivers need to be in place BEFORE opening your sequencer.

also, we cannot see which ASIO dest module you are using. the ASIO source and dest modules much match and both must be present.

what do your sequencer's audio settings look like?

Post Reply